Alertus Desktop Asking for Admin Credentials Constantly

Issue

Alertus Desktop (UGAAlert) is asking for admin credentials. Hitting cancel does nothing. Providing the admin credentials causes additional errors.

Errors include: "FixPermissionsPrompt Type your password to allow this"

The issue is caused by Alertus not being able to write to the file /Library/Application Support/Alertus Technologies/Desktop Alert/aapid.

Environment

macOS

Resolution

Uninstall and Reinstall Alertus (UGAAlert) from the Managed Software Portal (Munki)

If you do not have the Managed Software Portal, please submit a ticket at helpdesk.franklin.uga.edu

Cause

A server update caused a corruption to a configuration file that the client can't properly recover from. Reinstalling the application re-writes the file and resolves the issue.